No Flash with Firefox 1.5

I am a huge fan of Mozilla’s Firefox browser and have been for over a year now. I recently upgraded to Firefox 1.5 and all of a sudden all Flash elements on websites never showed up. I first noticed it when I was logged in to my Google Analytics account and none of the cool dashboard stuff was showing up. I was confused for quite a while at first, and then realized that it was probably one of my many Firefox Extensions that I have installed. After disabling my extensions one by one, I discovered that it was the Adblock Extension. I love that extension, but I guess I’ll have it disabled until they make it compatible with Firefox 1.5.

By the way, I love Firefox 1.5. Although honestly I don’t really see a huge performance increase, I do like how if a site request times out or something, rather than popping that annoying dialog window, it just loads a page with a button on it. That makes things a whole lot better, since BYU’s wireless network often times has problems timing out.

2 thoughts on “No Flash with Firefox 1.5”

  1. I had the same problem with Adblock since migrating to the Firefox 1.5 Beta 1 a few months ago. At first I thought it was an issue with the beta, but the full-fledged version of 1.5 hasn’t helped matters either.

    I’ve just found a solution: a new version of Adblock is available now, but hasn’t yet been posted to Mozilla’s Firefox Extensions site. Download the file from this mirror to your Desktop:

    https://opensvn.csie.org/…/adblock-dev.xpi

    Now click and drag the icon into an open Firefox window. That should install the new version. Hope it works for you!

Comments are closed.